British Astronomical Association
Supporting amateur astronomers since 1890

Secondary menu

Main menu

Home Forums Website News and Help
Terms of use

Forum error messages

6 posts / 0 new
Last post
Roy Hughes's picture
Offline
Last seen: 5 hours 40 min ago
Joined: 04/03/2014 - 12:54
Forum error messages

Over the last few days a strange error message box has appeared on forum pages, containing:

  • Notice: Undefined property: stdClass::$content in advanced_forum_get_reply_link() (line 883 of /home/baaweb/baa_website/drupal/sites/all/modules/advanced_forum/advanced_forum.module).
  • Notice: Undefined property: stdClass::$content in advanced_forum_get_reply_link() (line 883 of /home/baaweb/baa_website/drupal/sites/all/modules/advanced_forum/advanced_forum.module).
  • Notice: Undefined property: stdClass::$content in advanced_forum_get_reply_link() (line 883 of /home/baaweb/baa_website/drupal/sites/all/modules/advanced_forum/advanced_forum.module).

This only appears on Firefox. Chrome does not show it. Both under Window 10 (home).

Is it just me or are others getting it too?

Roy

Xilman's picture
Offline
Last seen: 1 day 4 hours ago
Joined: 24/03/2018 - 15:17
<aol>Me too !!!!???!!?!!!</aol>

I thought it was just me until your post.  It appears under Chromium, the free version of Chrome, on this Ubuntu system.  Not yetchecked with Firefux under Ubuntu.

I hope long time Usenet afficionados  here recognize the Subject line  It's quite a while since I last saw it on a net posting but these days nostalgia doesn't seem like it used to be.  Such cultural references should be preserved IMHO.

admin_dcf's picture
Offline
Last seen: 4 days 19 hours ago
Joined: 10/01/2013 - 12:42
Security update

Roy,

About 10 days ago I installed a security update to the forum software that we use, Drupal's Advanced Forum package.

Judging from the discussion forums associated with Advanced Forum, they mucked something up in a security update, so a lot of Drupal websites are currently being plagued by these errors.

It's unlikely to be affected by which web browser you use. I think it's fair more likely that it will occur on a few specific forum posts which unluckily happen to trigger this error condition.

Being free software, Drupal unfortunately tends to take its time about fixing problems, so I wouldn't hold my breath for a quick fix to this. We do have the option to remove the latest security update if this becomes a really serious problem, but I'd prefer to avoid doing that if at all possible!

Best wishes,

Dominic.

David Basey's picture
Offline
Last seen: 1 hour 2 min ago
Joined: 07/03/2014 - 17:24
Dominic,

Dominic,

I don't think it s just a few forum posts, for example I can get it intermittently on the home page as well. Refreshing the screen normally makes it go away.

Curiously, when I entered this topic the error was not there. Hitting 'reply' to post this entry brought it up, previewing it made it go away again!

Best Wishes,

David

admin_dcf's picture
Offline
Last seen: 4 days 19 hours ago
Joined: 10/01/2013 - 12:42
Due to the slightly weird way

Due to the slightly weird way that Drupal works, error messages often get delayed until the next page you view after the one that generated the problem. So you could see these errors on any page of the site, if you view that page immediately after visiting one of the troublesome forum posts.

For the time being, I've installed a filter which I think should be hiding these errors. The errors are still happening, which isn't ideal, but I think you shouldn't see them any longer.

Roy Hughes's picture
Offline
Last seen: 5 hours 40 min ago
Joined: 04/03/2014 - 12:54
Still complaining about line

Still complaining about line 883... Oh well.

Roy